布香断事点网务中n可 蓝件的说明云发用区阿里港RC服
改进措施 :全网巡检,09:01,陆续启动冷机 ,部分实例的迁移恢复过程遇到一些异常情况 ,
服务影响
12月18日09:23,截至12:30,C和D 。此时,
阿里云
2022年12月25日
其中一个包间因消防喷淋启动,此时工程师排查到冷机异常 。影响了冷却系统的恢复时长 。问题分析和改进措施 。有效信息不够 。客户业务开始受到影响,13:47NAT产品完成收尾逃逸。改进措施 :全面检查机房基础设施管控系统 ,18:55 ,数据库、可用性最低跌至20% 。影响面扩大到香港可用区C的EBS、k8s用户控制台操作也受到了故障影响。新扩容的ECS管控系统启动时依赖的中间件服务部署在可用区C机房,
总结
最后,阿里云在香港Region可用区C提供了2种类型的OSS服务 ,阿里云香港Region可用区C部分RDS实例出现不可用的报警 。因大量可用区C的客户在香港其他可用区新购ECS实例,并通过常态化演练强化执行。其中,ECS管控依赖的自定义镜像数据服务 ,
自10:30开始,冷机系统故障恢复时间过长
原因分析:机房冷却系统缺水进气形成气阻 ,防止内部状态死锁从而影响故障的恢复 。增加了后续恢复难度和时长。影响水路循环导致4台主冷机服务异常,机房温度稳定。15:20 ,通知机房服务商进行现场排查。将冷机从群控调整为独立运行后,工程师启动数据库应急切换预案流程。我们持续建议您采用全链路多可用区的业务架构设计 ,机房温度趋于稳定。我们提供了克隆实例、温度开始下降 。继续多次对冷机设备进行操作 ,受影响的服务器停机数量持续增加 ,冷却水管路及冷机冷凝器进行手工补水排气操作,
2、并进行必要的数据完整性检查 。力求更简单有效,阿里云本着负责任的态度公布了这次中断事件的完整报告 ,欲了解更多产品请访问阿里云官网:https://ourl.co/aliho
北京时间2022年12月18日 ,冷机群控解锁完成并独立运行 ,需要依赖故障机房的恢复。整体优化多AZ产品高可用设计,此时,
4、进行辅助散热和应急通风。数据检查以及风险评估完成,避免出现依赖OSS单AZ和中间件单AZ的问题。09:09,并尽快处理赔偿事宜。NAT有分钟级业务受损。公告等通知手段,因不支持跨可用区切换 ,随着温度继续升高,尽快上线新版的阿里云服务健康状态页面(Status Page),稳定性是云服务的生命线 ,
12月18日10:17开始 ,机房服务商按应急预案对异常冷机进行4+4主备切换以及重启 ,4台冷机恢复到正常制冷量。依赖可用区C的单AZ冗余版本的OSS服务,阿里云工程师对部分高温包间启动服务器关机操作。12月18日11:21,Privatelink以及少量GA实例)在此次故障中受到影响。提高对故障的排查和定位速度;在设施管控逻辑层面,部分实例在购买成功之后会出现启动失败的现象,仅少量实例实现有效迁移。工程师对服务器进行停机操作 ,导致一机房包间温度达到临界值触发消防系统喷淋,花费了较多的时间进行完整性检验工作。我们将尽一切努力从此次事件中吸取经验教训,导致可用区 B 管控服务资源不足 。从11:07至18:26中断了服务 。以应对各种可能的意外事件 。电源柜和多列机柜进水,阿里云香港可用区C的部分存储服务OSS开始受到停机影响,香港Region可用区C部分ECS服务器开始出现停机,分批启动服务器,因为保持数据的完整性至关重要 ,随着该可用区受故障影响的主机范围扩大,恢复服务前,此次香港Region可用区C服务中断事件,部署在可用区B 、阿里云工程师开始进行服务启动恢复,如果指定了自定义镜像 ,
21:36,无法通过代理地址访问RDS实例 。阿里云香港Region可用区C发生大规模服务中断事件 。在监控数据采集层面,我们要向所有受到故障影响的客户公开致歉,启动制冷异常应急预案 ,因机房冷却系统的群控逻辑 ,启动4台备冷机时因主备共用的水路循环系统气阻导致启动失败。补水排气耗时2小时57分钟 ,12:45完成SLB等大部分网络产品可用区容灾逃逸,但影响了香港Region ECS管控服务(Control Plane)的正常使用 。
改进措施 :提升故障影响和客户影响的快速评估和识别拉取能力。联系冷机设备供应商到现场排查。C可用区双机房容灾 ,从18:26开始 ,工程师随后继续通过相同方法对其他冷机进行操作。无法通过重试解决。各网络产品在故障期间保持了业务连续性 ,DTS等大部分跨可用区实例完成跨可用区切换 。但系统仍然无法保持稳定运行。未进行服务器上电。由于自定义镜像数据服务依赖可用区C的单AZ冗余版本的OSS服务,
阿里云网络少量单可用区产品(如 :VPN 、
阿里云香港可用区C的故障,客户在使用RunInstances/CreateInstance API购买新ECS实例时,
12月18日10:37,在这次事件中依然可以维持业务运行。工程师对这个包间的服务器进行了仔细的数据安全检查 ,对我们的客户至关重要 。让客户可以更便捷地了解故障事件对各类产品服务的影响 。部分单可用区实例以及单可用区高可用实例,持续提升云服务的稳定性 ,包间温度逐渐升高 ,存储、解锁群控逻辑启动4台冷机耗时3小时32分钟 。但由于底层服务资源的限制 ,经过复盘,此时客户暂不会感知,由于大量可用区C的客户在香港其他可用区新购实例,同时在多个可用区运行业务的客户,Status Page页面信息更新不及时引发客户困惑 。影响数据安全 ,期间 ,
改进措施:加强机房服务商管理 ,这里花费了一些必要的时间 。除上述少量单可用区产品以外,也是阿里云运营十多年来持续时间最长的一次大规模故障。对冷塔、触发同可用区内宕机迁移 。现场处置不及时导致触发消防喷淋
原因分析:随着机房冷却系统失效 ,同时可用区C的ECS实例拉起恢复动作引入的流量,网络 、随着机房制冷设备恢复 ,提升精细度,大部分机房包间服务器陆续启动并完成检查,原因定位耗时3小时34分钟,
3.客户在香港地域新购ECS等管控操作失败
原因分析 :ECS管控系统为B 、部分Dataworks、导致客户新购实例后出现启动失败的现象。手工修改冷机配置,并持续观察温升情况。部分服务器开始受到影响 。故障信息发布不够及时透明
原因分析:故障发生后阿里云启动对客钉群、
我们注意到,RDS MySQL与Redis、确保系统自动切换逻辑符合预期 ,实例迁移等临时性恢复方案 ,无法单台独立启动冷机 ,我们协助相关客户通过临时切换到使用RDS主实例的地址访问来进行恢复 。
以下内容转自阿里云官方,大数据集群进行降载处理 。同时保证手工切换的准确性 ,其中一个包间因高温触发了强制消防喷淋。14:47 ,在此次故障中 ,存储服务器重新分批启动 。为避免可能出现的高温消防问题,导致较长时间内无法扩容。MongoDB、OSS 、冷机设备供应商到场,但操作失败,整个过程中 ,19:47,阿里云监控到该机房多个包间温升告警,扩大覆盖度 ,对很多客户的业务产生重大影响 ,单AZ本地冗余LRS服务有部分服务器因消防问题需要做隔离处理 。部分机器硬件损坏,OSS同城冗余ZRS服务基本没有受到影响。冷水机组无法恢复正常。C可用区故障后由B可用区对外提供服务 ,我们在这里向大家进一步说明故障情况、同时 ,API完全恢复可用为当日23:11。
处理过程
12月18日08:56 ,出现服务异常的实例数量随之增加 ,提高信息发布的速度 ,但发现无法稳定运行 ,明确温升场景下的业务侧关机和机房强制关电的预案 ,由于现场冷机处理进展缓慢 ,我们必须要确保数据可靠性,对于受故障影响的单机版实例及主备均在香港Region可用区C的高可用版实例 ,
12:30 ,09:17,阿里云监控到香港Region可用区C机房包间通道温控告警 ,一种是OSS本地冗余LRS服务(通常叫单AZ冗余服务) ,对于业务需要绝对高可用的客户,
问题分析与改进措施
1、




